Lost Legends has very low system requirements and supports a huge number of CPUs and graphics cards.

We support every single popular graphics card today:

  •  All Nvidia GeForce cards
  •  ATI: All Radeon
  •  Intel: All GMA 900 series, GMA HD series and later

Which already is about a bazillion cards.

Assuming you can find a driver, we also support most graphics cards with as little as 8 MB of memory going all the way back to 1998, including:

  • All Nvidia TNT
  • All ATI Rage 128 Pro and later
  • All Intel 740 and later
  • 3D Labs Permedia 2, Permedia 3, Oxygen VX1, Permedia 4 and later
  • TI Permedia 2c and later
  • 3Dfx Voodoo 3 and later
  • Guillemot TNT2 and later
  • Matrox G400 and later
  • ST Microelectronics Kyro 1 and later
  • SIS 315 and later, Xabre and later
  • Trident CyberBladeXP
  • S3 all Savage and later

Some things are changing, though.

We’re upgrading DirectX versions, and we’re also adding support for Nvidia PhysX.  These will allow us to create cooler high-end features than we have before.

Now, these changes are going to eliminate support for Windows 98; but we don’t think that’s much of an issue any more.

More updates on changes soon

See you in the dungeon!

Advertisements